Wymagany jest FlashPlayer w wersji 7. Możesz go pobrać tutaj.